On Fri, Oct 08, 2010 at 02:36:23PM +0400, Sergei Shtylyov wrote: > >+ while (loops--) { > >+ u64 ipd_clk_count = cvmx_read_csr(CVMX_IPD_CLK_COUNT); > >+ if (rdiv != 0) { > >+ ipd_clk_count = ipd_clk_count * rdiv; > > Why not: > > ipd_clk_count *= rdiv; Not sure if it really helps readability if the lhs of the assignment is only a simple variable. Either way, I changed it. Ralf