On Fri, Oct 28, 2005 at 07:37:27PM -0500, Zac Slade wrote: > I think that to get this part write might take a fundemental shift in the way > pv_write() and _pv_write() behave. What would be nice is to make pv_write() > distinguish between a pv_create calling it and a pv_resize. Then have _pv_write > only write the pv mda to the disk. By doing this _pv_write becomes generic and > allows for further extension. Also then we can probably implement atomicity for > pv updates (though updating a pv was not initially engineered into lvm it can > become very handy). I'm reluctant to extend pv_write - long term I want to get rid of it (and pv_read also) as PV operations are always awkward and getting in the way. Everything should be done with (new-style) VGs and LVs. pvcreate is also superfluous - I want to absorb it into vgcreate/vgextend etc. So every labelled volume will always belong to a VG - with enhanced vgsplit/vgmerge & allocation facilities. CVS now lets you create PVs on LVs - another step towards eliminating PVs. > Actually there is no need to use process_each_pv If you don't use it, you have to duplicate the logic in it as you have already done - incompletely (e.g. tag support is missing). > necessary or even wise to support resizing more than one pv at a time. If ppl want to do that, why stop them? > Can't we just borrow the code from pvcreate to manipulate the metadatacopies? Not yet. That problem needs solving as part of a general mda-manipulating feature. No point in doing it first for a rarely-used case. Alasdair -- agk@redhat.com _______________________________________________ linux-lvm mailing list linux-lvm@redhat.com https://www.redhat.com/mailman/listinfo/linux-lvm read the LVM HOW-TO at http://tldp.org/HOWTO/LVM-HOWTO/