On Thu, Nov 24, 2011 at 10:29:14AM -0500, Lars-Peter Clausen wrote: > In ancient times it was necessary to manually initialize the bus field of an > spi_driver to spi_bus_type. These days this is done in spi_driver_register(), s/spi_driver_register/spi_register_driver/ Otherwise Acked-by: Guenter Roeck <guenter.roeck@xxxxxxxxxxxx> Jean, ok if I take this and the others, or do you want to handle it ? Guenter > so we can drop the manual assignment. > > The patch was generated using the following coccinelle semantic patch: > // <smpl> > @@ > identifier _driver; > @@ > struct spi_driver _driver = { > .driver = { > - .bus = &spi_bus_type, > }, > }; > // </smpl> > > Signed-off-by: Lars-Peter Clausen <lars@xxxxxxxxxx> > Cc: Jean Delvare <khali@xxxxxxxxxxxx> > Cc: Guenter Roeck <guenter.roeck@xxxxxxxxxxxx> > Cc: lm-sensors@xxxxxxxxxxxxxx > --- > drivers/hwmon/ad7314.c | 1 - > drivers/hwmon/ads7871.c | 1 - > 2 files changed, 0 insertions(+), 2 deletions(-) > > diff --git a/drivers/hwmon/ad7314.c b/drivers/hwmon/ad7314.c > index 318e38e..5d760f3 100644 > --- a/drivers/hwmon/ad7314.c > +++ b/drivers/hwmon/ad7314.c > @@ -160,7 +160,6 @@ MODULE_DEVICE_TABLE(spi, ad7314_id); > static struct spi_driver ad7314_driver = { > .driver = { > .name = "ad7314", > - .bus = &spi_bus_type, > .owner = THIS_MODULE, > }, > .probe = ad7314_probe, > diff --git a/drivers/hwmon/ads7871.c b/drivers/hwmon/ads7871.c > index 5231934..04450f8 100644 > --- a/drivers/hwmon/ads7871.c > +++ b/drivers/hwmon/ads7871.c > @@ -227,7 +227,6 @@ static int __devexit ads7871_remove(struct spi_device *spi) > static struct spi_driver ads7871_driver = { > .driver = { > .name = DEVICE_NAME, > - .bus = &spi_bus_type, > .owner = THIS_MODULE, > }, > > -- > 1.7.7.1 > > -- Guenter Roeck Distinguished Engineer PDU IP Systems _______________________________________________ lm-sensors mailing list lm-sensors@xxxxxxxxxxxxxx http://lists.lm-sensors.org/mailman/listinfo/lm-sensors