On Wed, 3 Apr 2019 03:48:43 +0100 Mark Rutland <mark.rutland@xxxxxxx> wrote: > We currently have: > > ftrace_make_nop(mod, rec, addr) > ftrace_make_call(rec, addr) > ftrace_modify_call(rec, old_addr, new_addr) > > ... whereas we could have: > > ftrace_call_init(mod, rec) > ftrace_call_enable(rec, addr) > ftrace_call_disable(rec, addr) > ftrace_call_modify(rec, old_addr, new_addr) > > ... so we wouldn't need to special-case anything for initialization (and > don't need MCOUNT_ADDR at all), and it would be clearer as to what was > happening at each stage. Just a note. I would be OK if someone wants to work in changing the ftrace interface to be this. I'll review the code, but I don't have the cycles to implement such a change. -- Steve