> + if (ip->i_delayed_blks) > + found_blocks = true; > + else if (xfs_iext_lookup_extent(ip, &ip->i_df, end_fsb, &icur, &imap)) > found_blocks = true; This could be simplified a little bit by doing: if (ip->i_delayed_blks || xfs_iext_lookup_extent(ip, &ip->i_df, end_fsb, &icur, &imap)) found_blocks = true; but otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>