On Mon, Dec 04, 2023 at 05:55:26AM +0100, Christoph Hellwig wrote: > > + */ > > +uint8_t > > +xfs_compute_rextslog( > > + xfs_rtbxlen_t rtextents) > > +{ > > + return rtextents ? xfs_highbit32(rtextents) : 0; > > It might just be a personal pet peeve, but I find a good old if much > more readable for this: > > if (!rtextents) > return 0; > return xfs_highbit32(rtextents); > > Otherwise looks good: Same here. I'll adjust it in the next patch, since this one is the copypastahappy hoist. --D > Reviewed-by: Christoph Hellwig <hch@xxxxxx> > >