> + */ > +uint8_t > +xfs_compute_rextslog( > + xfs_rtbxlen_t rtextents) > +{ > + return rtextents ? xfs_highbit32(rtextents) : 0; It might just be a personal pet peeve, but I find a good old if much more readable for this: if (!rtextents) return 0; return xfs_highbit32(rtextents); Otherwise looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>