On Wed, Jun 02, 2021 at 03:25:30PM -0700, Darrick J. Wong wrote: > From: Darrick J. Wong <djwong@xxxxxxxxxx> > > Disentangle the dqrele_all inode grab code from the "generic" inode walk > grabbing code, and and use the opportunity to document why the dqrele > grab function does what it does. Since xfs_inode_walk_ag_grab is now > only used for blockgc, rename it to reflect that. > > Ultimately, there will be four reasons to perform a walk of incore > inodes: quotaoff dquote releasing (dqrele), garbage collection of > speculative preallocations (blockgc), reclamation of incore inodes > (reclaim), and deferred inactivation (inodegc). Each of these four have > their own slightly different criteria for deciding if they want to > handle an inode, so it makes more sense to have four cohesive igrab > functions than one confusing parameteric grab function like we do now. > > Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx> > --- > fs/xfs/xfs_icache.c | 71 +++++++++++++++++++++++++++++++++++++++++++++++---- > 1 file changed, 66 insertions(+), 5 deletions(-) Looks fine. Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> -- Dave Chinner david@xxxxxxxxxxxxx