On Wed, Feb 19, 2020 at 05:43:49PM -0800, Darrick J. Wong wrote: > +/* Prepare an uncached buffer, ready to write something out. */ > +static inline struct xfs_buf * > +get_write_buf( > + struct xfs_buftarg *btp, > + xfs_daddr_t daddr, > + int bblen) > +{ > + struct xfs_buf *bp; > + > + bp = libxfs_buf_get_uncached(btp, bblen, 0); > + bp->b_bn = daddr; > + bp->b_maps[0].bm_bn = daddr; > + return bp; > +} I'd call this alloc_write_buf. But the patch itself looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>