On Wed, Jun 26, 2019 at 5:51 PM Eric Sandeen <sandeen@xxxxxxxxxxx> wrote: > > rename and rearrange some of the vars related to using an open > file number as the source file, so that we don't temporarily > store a non-fd number in a var called "fd," and do the fd > assignment in a consistent code location. > > Signed-off-by: Eric Sandeen <sandeen@xxxxxxxxxx> > --- > > Amir, what do you think about this tweak, just for maintainability > I'd prefer to only assign an actual fd to "fd," and handle that > assignment in the same code location for both invocation options. > Thoughts? Not a big deal either way. I think that looks much better. ... > + } else > + fd = filetable[src_file_nr].fd; I would match else { } to if { }. Other than that, looks good. You may add: Reviewed-by: Amir Goldstein <amir73il@xxxxxxxxx> Thanks, Amir.