On Tue, Jan 15, 2019 at 09:08:49AM -0800, Darrick J. Wong wrote: > From: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > Refactor xfs_vn_getattr to use generic_fillattr to fill out parts of the > kstat structure instead of open-coding the same pieces. This eliminates > redundant code and fixes a bug where we fail to set the AUTOMOUNT > attribute. Obviously, we retain all the xfs-specific parts. I find the idea of writing the same values twice for something like stat that is pretty performane critical rather odd. I'd much rather just fix the XFS version up to set the automount attribute, and clear STATX_ATIME for noatime inodes.