Re: [PATCH] xfs: use generic fillattr to reduce redundant code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Jan 15, 2019 at 09:08:49AM -0800, Darrick J. Wong wrote:
> From: Darrick J. Wong <darrick.wong@xxxxxxxxxx>
> 
> Refactor xfs_vn_getattr to use generic_fillattr to fill out parts of the
> kstat structure instead of open-coding the same pieces.  This eliminates
> redundant code and fixes a bug where we fail to set the AUTOMOUNT
> attribute.  Obviously, we retain all the xfs-specific parts.
> 
> Signed-off-by: Darrick J. Wong <darrick.wong@xxxxxxxxxx>
> ---
>  fs/xfs/xfs_iops.c |   10 +---------
>  1 file changed, 1 insertion(+), 9 deletions(-)
> 
> diff --git a/fs/xfs/xfs_iops.c b/fs/xfs/xfs_iops.c
> index f48ffd7a8d3e..169bd7824479 100644
> --- a/fs/xfs/xfs_iops.c
> +++ b/fs/xfs/xfs_iops.c
> @@ -501,16 +501,9 @@ xfs_vn_getattr(
>  	if (XFS_FORCED_SHUTDOWN(mp))
>  		return -EIO;
>  
> +	generic_fillattr(inode, stat);
>  	stat->size = XFS_ISIZE(ip);

Maybe a comment to indicate that we're overwriting some of the
fields that generic_fillattr() also set from the VFS inode, so we
need to call it first before filling out the specific XFS
information?

Cheers,

Dave.
-- 
Dave Chinner
david@xxxxxxxxxxxxx



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux