On Thu, Apr 19, 2018 at 11:13:02AM +0200, Carlos Maiolino wrote: > On Wed, Apr 18, 2018 at 08:44:35AM -0700, Darrick J. Wong wrote: > > On Wed, Apr 18, 2018 at 11:49:35AM +0200, Carlos Maiolino wrote: > > > > There are two possible magics for attr3 blocks -- this one, which is for > > remote attr value blocks, and the xfs_da3_blkinfo magic for the attr > > leaf and da node blocks. Can you please fish out the second magic and > > print that too? > > > > Looks otherwise reasonable, and certainly better than the ASSERT. > > > > --D > > > > What do you think about this output. Using attr3 type trying to print a > directory's leaf block. > > xfs_db> type attr3 > Unknown attribute buffer type! > xfs_db> p > Unrecognized attr3 block, attempting to print magic numbers and/or blkinfo: > Unrecognized attr3 block, attempting to print magic numbers and/or blkinfo: > hdr.magic = 0 > hdr.info.hdr.forw = 0 > hdr.info.hdr.back = 0 > hdr.info.hdr.magic = 0x3df1 I like it better, though on further thought I think I like better the idea of printing the contents of all potential magic numbers: For a block starting with: 0xDE 0xAD 0xBE 0xEF 0xCA 0xFE 0xF0 0x0D 0xBA 0xAD... xfs_db> p Unrecognized attr3 block, attempting to print magic numbers and/or blkinfo: unknown.blockhdr.magic = 0xDEADBEEF unknown.da_blkinfo.magic = 0xBAAD unknown.inode.magic = 0xDEAD --D > hdr.info.crc = 0x72e2e910 (correct) > hdr.info.bno = 64 > hdr.info.lsn = 0x300002833 > hdr.info.uuid = 2b21796f-7f81-4cec-b583-968c55b7f4bb > hdr.info.owner = 99 > xfs_db> > > -- > Carlos > -- > To unsubscribe from this list: send the line "unsubscribe linux-xfs" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html