On Sun, 2017-12-17 at 09:37 +1100, Dave Chinner wrote: > On Sat, Dec 16, 2017 at 08:46:38AM -0500, Jeff Layton wrote: > > From: Jeff Layton <jlayton@xxxxxxxxxx> > > > > Add a documentation blob that explains what the i_version field is, how > > it is expected to work, and how it is currently implemented by various > > filesystems. > > > > We already have inode_inc_iversion. Add several other functions for > > manipulating and accessing the i_version counter. For now, the > > implementation is trivial and basically works the way that all of the > > open-coded i_version accesses work today. > > > > Future patches will convert existing users of i_version to use the new > > API, and then convert the backend implementation to do things more > > efficiently. > > > > Signed-off-by: Jeff Layton <jlayton@xxxxxxxxxx> > > --- > > include/linux/fs.h | 200 ++++++++++++++++++++++++++++++++++++++++++++++++++--- > > 1 file changed, 192 insertions(+), 8 deletions(-) > > Just a random sunday morning coffee musing.... > > I was just wondering if it would be better to split this stuff out > into it's own header file now? include/linux/fs.h is aleady a > massive header file (~3500 lines) and changes cause tree-wide > rebuilds, so maybe it would be better to split relatively isolated > functionality like this out while it's being reworked and you're > already touching every file that uses it? > > Cheers, > > Dave. That's a good idea. Let me do that and I'll re-post. Thanks, -- Jeff Layton <jlayton@xxxxxxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html