On Mon, Nov 24, 2014 at 12:53 PM, Christian Borntraeger <borntraeger@xxxxxxxxxx> wrote: > > That looks like a lot of changes all over ACCESS_ONCE -> ASSIGN_ONCE: > git grep "ACCESS_ONCE.*=.*" > gives me 200 placea not in Documentation. Yeah, that's a bit annoying. How about a combination of the two: - accept the fact that right now ACCESS_ONCE() is fairly widespread (even for writing) - but also admit that we'd be better off with a nicer interface and make the solution be: - make ACCESS_ONCE() only work on scalars, and deprecate it - add new "read_once()" and "write_once()" interfaces that *do* work on (appropriately sized) structures and unions, and start migrating things over. In particular, start with the ones that can no longer use ACCESS_ONCE() because they aren't scalar.. That second point would make the conversion patches actually easier to read. Instead of this: static inline int arch_spin_is_locked(arch_spinlock_t *lock) { - struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets); + arch_spinlock_t tmp = {}; - return tmp.tail != tmp.head; + tmp.head_tail =ACCESS_ONCE(lock->head_tail); + return tmp.tickets.tail != tmp.tickets.head; } which isn't *complex*, but is also not an obvious conversion, we'd have just static inline int arch_spin_is_locked(arch_spinlock_t *lock) { - struct __raw_tickets tmp = ACCESS_ONCE(lock->tickets); - struct __raw_tickets tmp = read_once(lock->tickets); return tmp.tail != tmp.head; } which is a much simpler and more obvious change. And then we could slowly try to migrate existing ACCESS_ONCE() users over (particularly writers). Hmm? Too much? Linus -- To unsubscribe from this list: send the line "unsubscribe linux-x86_64" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html