On Tue, Jan 31, 2012 at 7:39 AM, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > Why DFS & radar detection? I mean, why not just call it CMD_RADAR_DETECT or > so? > will rename it to CMD_RADAR_DETECT >> + * >> + * @dfs_start_radar_detection: Start radar detection in the driver. > > > ditto here will rename it to start_radar_detection > > >> @@ -3216,6 +3221,17 @@ void cfg80211_cqm_rssi_notify(struct net_device >> *dev, >> gfp_t gfp); >> >> /** >> + * cfg80211_radar_detected_notify - radar detection event > > > The _notify suffix seems useless, maybe remove it? > most of the function here use this suffix, but I don't mind to remove it .. > >> + * @dev: network device >> + * @freq: radar detected on this channel frequency > > > unit? > ok > >> +static int nl80211_dfs_start_radar_detection(struct sk_buff *skb, >> + struct genl_info *info) >> +{ >> + struct cfg80211_registered_device *rdev = info->user_ptr[0]; >> + struct net_device *dev = info->user_ptr[1]; >> + >> + ASSERT_RDEV_LOCK(rdev); > > > That assert isn't really worth much here. > will remove it also from: nl80211_dfs_en_tx, nl80211_ap_channel_switch > > How do you *end* radar detection? What channel does it apply to? Any channel > you're on? The channel you were on when it was enabled? Once we start radar detection, it should continuously monitor for radar until we switch from this channel. The command applies to current operational channel. -- Thanks, Victor. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html