On 1/26/2012 4:37 AM, Victor Goldenshtein wrote:
+ * @NL80211_CMD_DFS_RADAR_DETECTION: Start radar detection in the
+ * driver/HW. Once radar detected usermode notified with this event.
Why DFS & radar detection? I mean, why not just call it CMD_RADAR_DETECT
or so?
+ *
+ * @dfs_start_radar_detection: Start radar detection in the driver.
ditto here
@@ -3216,6 +3221,17 @@ void cfg80211_cqm_rssi_notify(struct net_device *dev,
gfp_t gfp);
/**
+ * cfg80211_radar_detected_notify - radar detection event
The _notify suffix seems useless, maybe remove it?
+ * @dev: network device
+ * @freq: radar detected on this channel frequency
unit?
+static int nl80211_dfs_start_radar_detection(struct sk_buff *skb,
+ struct genl_info *info)
+{
+ struct cfg80211_registered_device *rdev = info->user_ptr[0];
+ struct net_device *dev = info->user_ptr[1];
+
+ ASSERT_RDEV_LOCK(rdev);
That assert isn't really worth much here.
How do you *end* radar detection? What channel does it apply to? Any
channel you're on? The channel you were on when it was enabled?
johannes
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html