On Wed, 2011-07-13 at 17:54 +0530, Rajkumar Manoharan wrote: > Add 20/40 BSS coexistence and intolerant channel report IEs. Can you make the subject "wireless" or "ieee80211" instead of "mac80211"? > +/** > + * struct ieee80211_2040_bss_coex_ie > + * > + * This structure refers to "20/40 BSS Coexistence information element" > + */ That documentation is incomplete. > +struct ieee80211_2040_bss_coex_ie { > + u8 element_id; > + u8 length; > +#define IEEE80211_2040_BC_INFO_REQ 0x01 > +#define IEEE80211_2040_BC_40MHZ_INTOL 0x02 > +#define IEEE80211_2040_BC_20MHZ_WIDTH_REQ 0x04 > +#define IEEE80211_2040_BC_OBSS_SCAN_EXMPT_REQ 0x08 > +#define IEEE80211_2040_BC_OBSS_SCAN_EXMPT_GRNT 0x10 Please don't define them inside the struct, the docbook processing doesn't like that. Also BIT() would be nice to be more readable, and maybe make them an enum so they can have docs? > +/** > + * struct ieee80211_2040_intol_chan_report > + * > + * This structure refers to "20/40 BSS Intolerant Channel Report" > + */ Again incomplete docs. Come to think of it, maybe give pointers to the spec? > +struct ieee80211_2040_intol_chan_report { > + u8 element_id; > + u8 length; > + u8 reg_class; > + u8 variable[0]; > +} __packed; Does that variable[] really belong to the report? Didn't check now. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html