On Mon, Dec 27, 2010 at 15:11, Luciano Coelho <luciano.coelho@xxxxxxxxx> wrote: > On Wed, 2010-12-22 at 16:27 +0200, ext Arik Nemtsov wrote: >> Configure AP-specific beacon and probe response templates. >> Start the AP when beaconing is enabled. >> >> Signed-off-by: Arik Nemtsov <arik@xxxxxxxxxx> >> --- > > [...] > >> static void wl1271_op_bss_info_changed(struct ieee80211_hw *hw, >> @@ -1898,73 +1900,84 @@ static void wl1271_op_bss_info_changed(struct ieee80211_hw *hw, > > This whole wl1271_op_bss_info_changed() function was already quite long > and hard to read. Now, with support for AP and STA, it got even worse. > I think this should be broken down into smaller functions. No need to > clean the whole function up now, but would it be possible to separate at > least the AP and STA parts into separate functions? Sounds like a good idea. I'll separate it into 3 functions - common, ap and sta/ibss. > > >> @@ -1983,11 +2018,11 @@ static void wl1271_op_bss_info_changed(struct ieee80211_hw *hw, >> bss_conf->cqm_rssi_thold, >> bss_conf->cqm_rssi_hyst); >> if (ret < 0) >> - goto out; >> + goto out_sleep; > > Hmmm, nice catch. We were going out without sleeping in case of error > here. But this is a cross-patch change, could you separate it and send > as a standalone patch? Sure. Regards, Arik -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html