Holger Schurig <holgerschurig@...> writes: > > +static int ieee80211_dump_survey(struct wiphy *wiphy, struct net_device *dev, > + int idx, struct survey_info *survey) > +{ > + struct ieee80211_local *local = wdev_priv(dev->ieee80211_ptr); > + > + if (!local->ops->get_survey) > + return -EOPNOTSUPP; The check for the function is duplicated in drv_get_survey. I think the wrapper should be called unconditionally. > + > + return drv_get_survey(local, idx, survey); > +} > + -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html