On Thu, 2010-04-08 at 15:25 -0400, Luis R. Rodriguez wrote: > +#define AR_SREV_9300_20_OR_LATER(_ah) \ > + (((_ah)->hw_version.macVersion > AR_SREV_VERSION_9300) || \ > + (((_ah)->hw_version.macVersion == AR_SREV_VERSION_9300) && \ > + ((_ah)->hw_version.macRev >= AR_SREV_REVISION_9300_20))) I wonder if AR_SREV_9300_OR_LATER would be a better name, considering that AR9300 1.0 won't ever be supported. For the same reason, the revision check seems excessive. Someone seeing AR_SREV_9300_20_OR_LATER in the code could assume that it won't match devices that come after AR9300, but only devices of version AR9300 and revision 2.0 and newer. AR_SREV_9300_OR_LATER won't have that ambiguity. -- Regards, Pavel Roskin -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html