Hi David, > Signed-off-by: David Kilroy <kilroyd@xxxxxxxxxxxxxx> > --- > net/wireless/wext-compat.c | 12 ++++++++++-- > 1 files changed, 10 insertions(+), 2 deletions(-) > > diff --git a/net/wireless/wext-compat.c b/net/wireless/wext-compat.c > index 711e00a..b132f85 100644 > --- a/net/wireless/wext-compat.c > +++ b/net/wireless/wext-compat.c > @@ -204,8 +204,16 @@ int cfg80211_wext_giwrange(struct net_device *dev, > range->avg_qual.noise = range->max_qual.noise / 2; > range->avg_qual.updated = range->max_qual.updated; > > - range->enc_capa = IW_ENC_CAPA_WPA | IW_ENC_CAPA_WPA2 | > - IW_ENC_CAPA_CIPHER_TKIP | IW_ENC_CAPA_CIPHER_CCMP; > + range->enc_capa = IW_ENC_CAPA_WPA | IW_ENC_CAPA_WPA2; > + > + for (c = 0; c < wdev->wiphy->n_cipher_suites; c++) { > + u32 suite = wdev->wiphy->cipher_suites[c]; > + > + if (suite == WLAN_CIPHER_SUITE_TKIP) > + range->enc_capa |= IW_ENC_CAPA_CIPHER_TKIP; > + else if (suite == WLAN_CIPHER_SUITE_CCMP) > + range->enc_capa |= IW_ENC_CAPA_CIPHER_CCMP; this is a personal preference, but a switch statement make the code way easier to read here. Regards Marcel -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html