On Tue, Jan 23, 2024 at 11:50:34AM +0000, Kalle Valo wrote: > Kees Cook <keescook@xxxxxxxxxxxx> wrote: > > > In an effort to separate intentional arithmetic wrap-around from > > unexpected wrap-around, we need to refactor places that depend on this > > kind of math. One of the most common code patterns of this is: > > > > VAR + value < VAR > > > > Notably, this is considered "undefined behavior" for signed and pointer > > types, which the kernel works around by using the -fno-strict-overflow > > option in the build[1] (which used to just be -fwrapv). Regardless, we > > want to get the kernel source to the position where we can meaningfully > > instrument arithmetic wrap-around conditions and catch them when they > > are unexpected, regardless of whether they are signed[2], unsigned[3], > > or pointer[4] types. > > > > Refactor open-coded wrap-around addition test to use add_would_overflow(). > > This paves the way to enabling the wrap-around sanitizers in the future. > > > > Link: https://git.kernel.org/linus/68df3755e383e6fecf2354a67b08f92f18536594 [1] > > Link: https://github.com/KSPP/linux/issues/26 [2] > > Link: https://github.com/KSPP/linux/issues/27 [3] > > Link: https://github.com/KSPP/linux/issues/344 [4] > > Cc: Kalle Valo <kvalo@xxxxxxxxxx> > > Cc: Johannes Berg <johannes.berg@xxxxxxxxx> > > Cc: Max Chen <mxchen@xxxxxxxxxxxxxx> > > Cc: Yang Shen <shenyang39@xxxxxxxxxx> > > Cc: linux-wireless@xxxxxxxxxxxxxxx > > Signed-off-by: Kees Cook <keescook@xxxxxxxxxxxx> > > Acked-by: Kalle Valo <kvalo@xxxxxxxxxx> > > If you can edit before commit please add "wifi:" prefix to the wireless patches: > > ERROR: 'wifi:' prefix missing: '[PATCH 41/82] wil6210: Refactor intentional wrap-around test' > ERROR: 'wifi:' prefix missing: '[PATCH 62/82] mwifiex: pcie: Refactor intentional wrap-around test' Ah yes, thank you! I will adjust them. -Kees > > 2 patches set to Not Applicable. > > 13526631 [41/82] wil6210: Refactor intentional wrap-around test > 13526632 [62/82] mwifiex: pcie: Refactor intentional wrap-around test > > -- > https://patchwork.kernel.org/project/linux-wireless/patch/20240123002814.1396804-41-keescook@xxxxxxxxxxxx/ > > https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches > -- Kees Cook