04.08.2021 18:34, Linus Walleij пишет: > + bool tested_board_variant; What about s/tested/tried/? > void (*done)(struct device *dev, int err, struct brcmf_fw_request *req); > }; > > -static void brcmf_fw_request_done(const struct firmware *fw, void *ctx); > - > #ifdef CONFIG_EFI > /* In some cases the EFI-var stored nvram contains "ccode=ALL" or "ccode=XV" > * to specify "worldwide" compatible settings, but these 2 ccode-s do not work > @@ -638,11 +637,25 @@ static int brcmf_fw_request_firmware(const struct firmware **fw, > return request_firmware(fw, cur->path, fwctx->dev); > } > > -static void brcmf_fw_request_done(const struct firmware *fw, void *ctx) > +static void brcmf_fw_request_done_first(const struct firmware *fw, void *ctx) Is it really worthwhile to rename this function? There is no "done_second".