"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(*ev) + ev->num_neighbors * sizeof(struct wmi_neighbor_info) > > with: > > struct_size(ev, neighbor, ev->num_neighbors) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Signed-off-by: Kalle Valo <kvalo@xxxxxxxxxxxxxx> Patch applied to ath-next branch of ath.git, thanks. 83d9562b6478 ath6kl: wmi: use struct_size() helper -- https://patchwork.kernel.org/patch/10884343/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches