"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, change the following form: > > sizeof(*tbl) + num_entries * sizeof(struct wmi_bss_roam_info) > > to : > > struct_size(tbl, info, num_entries) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Signed-off-by: Kalle Valo <kvalo@xxxxxxxxxxxxxx> Patch applied to ath-next branch of ath.git, thanks. df75786b9233 ath6kl: debug: Use struct_size() helper -- https://patchwork.kernel.org/patch/10884039/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches