On Thu, 2008-07-03 at 20:45 +0300, Tomas Winkler wrote: > On Thu, Jul 3, 2008 at 8:33 PM, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > > On Thu, 2008-07-03 at 20:26 +0300, Tomas Winkler wrote: > >> On Thu, Jul 3, 2008 at 8:07 PM, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > >> > > >> >> - netif_carrier_on(dev); > >> >> ifsta->flags |= IEEE80211_STA_PREV_BSSID_SET; > >> >> memcpy(ifsta->prev_bssid, sdata->u.sta.bssid, ETH_ALEN); > >> >> memcpy(wrqu.ap_addr.sa_data, sdata->u.sta.bssid, ETH_ALEN); > >> >> ieee80211_sta_send_associnfo(dev, ifsta); > >> >> } else { > >> >> + netif_carrier_off(dev); > >> >> ieee80211_sta_tear_down_BA_sessions(dev, ifsta->bssid); > >> >> ifsta->flags &= ~IEEE80211_STA_ASSOCIATED; > >> >> - netif_carrier_off(dev); > >> > > >> > Maybe it should then be symmetric so that callers of the function have > >> > to do it in both cases? Other than that, looks good. > >> > >> The sequence now is > >> configure association in the driver -> carrier_on ..... carrier_off > >> -> configure disassociation in the driver > >> > >> So this is already symmetric or I don't understand what you mean. > > > > Yes, the call sequence is symmetric, but I was thinking whether it would > > be better API-wise to have the caller of ieee80211_set_associated() do > > both carrier_on and carrier_off, instead of requiring that it calls > > carrier_on but calling carrier_off for it. > > I think it's actually okay to be inside and I would rather prefer to > split this function; there is already one function called > ieee80211_set_disassociated. But since we have to fix dissacosiation > anway and we need to investigate it more I would first use this little > fix. Sure ok, thanks for looking into this stuff. johannes
Attachment:
signature.asc
Description: This is a digitally signed message part