On Mon, 2015-05-25 at 07:37 +0000, Rahul Jain wrote: > diff --git a/net/wireless/util.c b/net/wireless/util.c [] > @@ -1340,10 +1340,7 @@ bool ieee80211_operating_class_to_band(u8 operating_class, > case 128 ... 130: > *band = IEEE80211_BAND_5GHZ; > return true; > - case 81: > - case 82: > - case 83: > - case 84: > + case 81 ... 84: > *band = IEEE80211_BAND_2GHZ; > return true; > case 180: While I don't find this particularly more readable, I would probably find it more readable in numeric ascending order and the case moved above BAND_5GHZ. Also, this function seems to be used only once in net/mac80211/spectmgmt.c Maybe it should be static in that file and not EXPORT_SYMBOL. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html