On Tue, 2014-01-21 at 12:09 +0100, Antonio Quartulli wrote: > struct rate_control_ops { > struct module *module; > const char *name; > @@ -4478,6 +4489,10 @@ struct rate_control_ops { > void (*add_sta_debugfs)(void *priv, void *priv_sta, > struct dentry *dir); > void (*remove_sta_debugfs)(void *priv, void *priv_sta); > + > + void (*get_minstrel_best_rate) > + (void *priv, void *priv_sta, > + struct ieee80211_minstrel_rate_info *info); > }; This, I think, is a terrible idea. Never mind the coding style (which too looks terrible imho), but this also bloats the struct for a single rate control algorithm's use only. I'd be much happier if you actually declared this to be something like "expected throughput" and did some calculations and made it generic. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html