On Wed, 2014-01-08 at 16:26 +0100, Michal Kazior wrote: > Unifies variable naming regarding radar detection > width. I think this is dangerous - "radar_detect_width" could easily be read as an enum value, rather than a bitfield. I do wonder why cfg80211_can_use_iftype_chan() gets passed a bitfield though, it might be smarter to make that get an enum value for added type checking. Actually I guess the reason is that there's no "no radar checking" value in the enum then ... At least for _widths, it's clear that it must be a bitfield since otherwise more than one width wouldn't be possible. > - if (radar_detect && !(c->radar_detect_widths & radar_detect)) > + if (radar_detect_width && !(c->radar_detect_widths & radar_detect_width)) That also makes it extend far beyond 80 columns. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html