Re: [1/3] watchdog: at91rm9200: Remove redundant of_match_ptr

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Oct 02, 2013 at 12:13:04PM +0530, Sachin Kamat wrote:
> Hi  Guenter,
> 
> On 2 October 2013 02:18, Guenter Roeck <linux@xxxxxxxxxxxx> wrote:
> > On Mon, Sep 30, 2013 at 12:42:51PM -0000, Sachin Kamat wrote:
> >> The data structure of_match_ptr() protects is always compiled in.
> >> Hence of_match_ptr() is not needed.
> >>
> >> Signed-off-by: Sachin Kamat <sachin.kamat@xxxxxxxxxx>
> >>
> >
> > Hi Sachin,
> >
> > I understand that the driver doesn't currently support to be built as module,
> > so of_match_ptr() is not really necessary. But unless I am missing something,
> > here isn't anything wrong with it either, not does it hurt to have it in place.
> >
> > So what is the benefit of this series ?
> 
> of_match_ptr() is a macro used to avoid undefined reference error if
> CONFIG_OF is used to selectively compile in or out the
> data structure. It is defined as follows:
> 
> #ifdef CONFIG_OF
> #define of_match_ptr(ptr) ptr
> #else
> #define of_match_ptr(ptr) NULL
> #endif
> 
> In the case of this series, none of the drivers use CONFIG_OF macro to
> compile out the data structure (i.e., the data structure is always
> defined).
> Hence the use of of_match_ptr() does not make any sense. Thus removing
> it to make the code look simpler for readability.
> 
> Hope this clarifies.

Ok, I'll accept that.

Acked-by: Guenter Roeck <linux@xxxxxxxxxxxx>
--
To unsubscribe from this list: send the line "unsubscribe linux-watchdog" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]

  Powered by Linux