On 11/20/24 at 11:28am, David Hildenbrand wrote: > On 20.11.24 10:42, Baoquan He wrote: > > On 11/15/24 at 10:59am, David Hildenbrand wrote: > > > On 15.11.24 10:44, Baoquan He wrote: > > > > On 10/25/24 at 05:11pm, David Hildenbrand wrote: > > > > > These defines are not related to /proc/kcore, move them to crash_dump.h > > > > > instead. While at it, rename "struct vmcore" to "struct > > > > > vmcore_mem_node", which is a more fitting name. > > > > > > > > Agree it's inappropriate to put the defintions in kcore.h. However for > > > > 'struct vmcore', it's only used in fs/proc/vmcore.c from my code > > > > serching, do you think if we can put it in fs/proc/vmcore.c directly? > > > > And 'struct vmcoredd_node' too. > > > > > > See the next patches and how virtio-mem will make use of the feactored out > > > functions. Not putting them as inline functions into a header will require > > > exporting symbols just do add a vmcore memory node to the list, which I want > > > to avoid -- overkill for these simple helpers. > > > > I see. It makes sense to put them in crash_dump.h. Thanks for > > explanation. > > > > I'll add these details to the description. Thanks. > > > > > > > > > > > > And about the renaming, with my understanding each instance of struct > > > > vmcore represents one memory region, isn't it a little confusing to be > > > > called vmcore_mem_node? I understand you probablly want to unify the > > > > vmcore and vmcoredd's naming. I have to admit I don't know vmcoredd well > > > > and its naming, while most of people have been knowing vmcore representing > > > > memory region very well. > > > > > > I chose "vmcore_mem_node" because it is a memory range stored in a list. > > > Note the symmetry with "vmcoredd_node" > > > > I would say the justification of naming "vmcore_mem_node" is to keep > > symmetry with "vmcoredd_node". If because it is a memory range, it really > > should not be called vmcore_mem_node. As we know, memory node has > > specific meaning in kernel, it's the memory range existing on a NUMA node. > > > > And vmcoredd is not a widely used feature. At least in fedora/RHEL, we > > leave it to customers themselves to use and handle, we don't support it. > > And we add 'novmcoredd' to kdump kernel cmdline by default to disable it > > in fedora/RHEL. So a rarely used feature should not be taken to decide > > the naming of a mature and and widely used feature's name. My personal > > opinion. > > It's a memory range that gets added to a list. So it's a node in a list ... > representing a memory range. :) I don't particularly care about the "node" > part here. Ah, I missed that about list node. There are list items, list entries and list nodes, I didn't think of list node at tht time. > > The old "struct vmcore" name is misleading: makes one believe it somehow > represents "/proc/vmcore", but it really doesn't. (see below on function > naming) Yeah, agree. struct vmcore is a concept of the whole logical file. > > > > > > > > > If there are strong feelings I can use a different name, but > > > > Yes, I would suggest we better keep the old name or take a more > > appropriate one if have to change. > > In light of patch #5 and #6, really only something like "vmcore_mem_node" > makes sense. Alternatively "vmcore_range" or "vmcore_mem_range". > > Leaving it as "struct vmcore" would mean that we had to do in #5 and #6: > > * vmcore_alloc_add_mem_node() -> vmcore_alloc_add() > * vmcore_free_mem_nodes() -> vmcore_free() > > Which would *really* be misleading, because we are not "freeing" the vmcore. > > Would "vmcore_range" work for you? Then we could do: > > * vmcore_alloc_add_mem_node() -> vmcore_alloc_add_range() > * vmcore_free_mem_nodes() -> vmcore_free_ranges() Yeah, vmcore_range is better, which won't cause misunderstanding. Thanks.