On Fri, Nov 28, 2014 at 01:10:57PM +0100, David Hildenbrand wrote: > > Add low level APIs to test/set/clear feature bits. > > For use by transports, to make it easier to > > write code independent of feature bit array format. > > > > Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx> > > --- > > include/linux/virtio_config.h | 53 ++++++++++++++++++++++++++++++++++++++++--- > > 1 file changed, 50 insertions(+), 3 deletions(-) > > > > As these functions really set feature bits, I would rather name them: > > virtio_has_feature ... > virtio_set_feature ... > virtio_clear_feature ... We have these as high level APIs for drivers. These are low level ones so need a different name. > But in general, this looks good to me! _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linuxfoundation.org/mailman/listinfo/virtualization