> Add low level APIs to test/set/clear feature bits. > For use by transports, to make it easier to > write code independent of feature bit array format. > > Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx> > --- > include/linux/virtio_config.h | 53 ++++++++++++++++++++++++++++++++++++++++--- > 1 file changed, 50 insertions(+), 3 deletions(-) > As these functions really set feature bits, I would rather name them: virtio_has_feature ... virtio_set_feature ... virtio_clear_feature ... But in general, this looks good to me! _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linuxfoundation.org/mailman/listinfo/virtualization