On Tue, Nov 12 2013, David Cohen wrote: > On 11/11/2013 03:55 PM, Michal Nazarewicz wrote: >> Come to think of it, perhaps even better helper would be: >> >> static inline size_t usb_ep_align_maybe( >> struct usb_gadget *gadget, struct usb_ep *ep, size_t len) { >> return gadget->quir_ep_out_aligned_size ? >> round_up(len, (size_t)ep->desc->wMaxPacketSize) : len; >> } > > The CPU time to check unsigned:1 and possibly jump is about the same as > round_up() itself. For readability matters, we can round_up() directly. I was proposing to have this function and than not have functions check for the flag. I.e. instead of if (gadget->quirk_ep_out_aligned_size) len = usb_ep_align_maxpacketsize(ep, len); the code would just be: len = usb_ep_align_maybe(gadget, ep, len); -- Best regards, _ _ .o. | Liege of Serenely Enlightened Majesty of o' \,=./ `o ..o | Computer Science, Michał “mina86” Nazarewicz (o o) ooo +--<mpn@xxxxxxxxxx>--<xmpp:mina86@xxxxxxxxxx>--ooO--(_)--Ooo--
Attachment:
signature.asc
Description: PGP signature