Re: [PATCH v5 1/5] usb: gadget: move bitflags to the end of usb_gadget struct

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Nov 11 2013, David Cohen wrote:
> This patch moves all bitflags to the end of usb_gadget struct in order
> to improve readability.
>
> Signed-off-by: David Cohen <david.a.cohen@xxxxxxxxxxxxxxx>

Acked-by: Michal Nazarewicz <mina86@xxxxxxxxxx>

> ---
>  include/linux/usb/gadget.h | 19 ++++++++++---------
>  1 file changed, 10 insertions(+), 9 deletions(-)
>
> diff --git a/include/linux/usb/gadget.h b/include/linux/usb/gadget.h
> index 942ef5e053bf..23b3bfd0a842 100644
> --- a/include/linux/usb/gadget.h
> +++ b/include/linux/usb/gadget.h
> @@ -485,6 +485,11 @@ struct usb_gadget_ops {
>   * @max_speed: Maximal speed the UDC can handle.  UDC must support this
>   *      and all slower speeds.
>   * @state: the state we are now (attached, suspended, configured, etc)
> + * @name: Identifies the controller hardware type.  Used in diagnostics
> + *	and sometimes configuration.
> + * @dev: Driver model state for this abstract device.
> + * @out_epnum: last used out ep number
> + * @in_epnum: last used in ep number
>   * @sg_supported: true if we can handle scatter-gather
>   * @is_otg: True if the USB device port uses a Mini-AB jack, so that the
>   *	gadget driver must provide a USB OTG descriptor.
> @@ -497,11 +502,6 @@ struct usb_gadget_ops {
>   *	only supports HNP on a different root port.
>   * @b_hnp_enable: OTG device feature flag, indicating that the A-Host
>   *	enabled HNP support.
> - * @name: Identifies the controller hardware type.  Used in diagnostics
> - *	and sometimes configuration.
> - * @dev: Driver model state for this abstract device.
> - * @out_epnum: last used out ep number
> - * @in_epnum: last used in ep number
>   *
>   * Gadgets have a mostly-portable "gadget driver" implementing device
>   * functions, handling all usb configurations and interfaces.  Gadget
> @@ -530,16 +530,17 @@ struct usb_gadget {
>  	enum usb_device_speed		speed;
>  	enum usb_device_speed		max_speed;
>  	enum usb_device_state		state;
> +	const char			*name;
> +	struct device			dev;
> +	unsigned			out_epnum;
> +	unsigned			in_epnum;
> +
>  	unsigned			sg_supported:1;
>  	unsigned			is_otg:1;
>  	unsigned			is_a_peripheral:1;
>  	unsigned			b_hnp_enable:1;
>  	unsigned			a_hnp_support:1;
>  	unsigned			a_alt_hnp_support:1;
> -	const char			*name;
> -	struct device			dev;
> -	unsigned			out_epnum;
> -	unsigned			in_epnum;
>  };
>  #define work_to_gadget(w)	(container_of((w), struct usb_gadget, work))
>  
> -- 
> 1.8.4.rc3
>

-- 
Best regards,                                         _     _
.o. | Liege of Serenely Enlightened Majesty of      o' \,=./ `o
..o | Computer Science,  Michał “mina86” Nazarewicz    (o o)
ooo +--<mpn@xxxxxxxxxx>--<xmpp:mina86@xxxxxxxxxx>--ooO--(_)--Ooo--

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux