Re: [PATCH 1/1] usb: chipidea: imx: include usbmisc_imx.c in ci_hdrc_imx.c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Aug 07, 2013 at 03:54:06PM +0800, Peter Chen wrote:
> On Wed, Aug 07, 2013 at 11:08:45AM +0200, Sascha Hauer wrote:
> > > > 
> > > > - Convert imx-usb-misc from a driver into something which is called
> > > >   directly
> > > > - add aliases
> > > > - change devicetree bindings (which causes pain and it's not explained why
> > > >   this is necessary at all)
> > > 
> > > Yes, I need to split doc from implementation.
> > 
> > No, you don't. You just have to explain *why* the bindings need to be
> > chaged.
> > 
> 
> OK, I will
> 
> > > 
> > > > - converts the misc stuff to regmap
> > > > 
> > > > Please split this up so that it can be reviewed.
> > > 
> > > The changes are all related to convert usbmisc_imx from a driver to something
> > > which can be called directly.
> > > 
> > > - usbmisc has #index-cells to indicate controller number, now, it is not
> > > a driver, we use aliases at controller driver to instead of it.
> > 
> > Why?
> > 
> 
> We need to know controller number, like pdev->id in the past.
> The registers at non core register is messy, the specific bit
> is for specific controller.

The controller number is present in the old binding:

fsl,usbmisc = <&usbmisc 1>;
                       ^^^

Merging the usbmisc stuff into the imx driver shouldn't be a reason to
change this binding.

Please get used to the fact that dt bindings cannot be changed easily
just because the newer binding looks nicer. They define an ABI and
breaking this ABI causes pain.

> 
> > > - When usbmisc_imx is a device, the register maps only one time.
> > > But ci_hdrc_imx will be several devices, the non-core register
> > > will be mapped several times, we have to use syscon to visit one register
> > > region among several devices.
> > 
> > Converting the imx-usb misc driver to regmap is fine, but I see no
> > reason to not make this a separate patch. This would make this much
> > easier to read.
> 
> You mean delete "reg" entry at usbmisc dts, and using noncore phandle
> at usbmisc_imx.c as the first patch, then, convert driver as separate
> file.

I mean: create a patch which converts the usbmisc driver to regmap and
base your other stuff on this patch.

Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux