On Fri, Jan 18, 2013 at 11:35:49PM +0300, Sergei Shtylyov wrote: > + /* > + * This is our custom open-coded lock, similar to r/w locks in concept. > + * It prevents usb-storage, usbfs, and /proc from simultaneous access. > + */ > + wait_queue_head_t excl_wait; > + spinlock_t excl_lock; > + unsigned int excl_type; I _really_ don't like open-coded locks, and given the wide range of existing kernel primitives, surely something that we already have can work here as well, right? I don't want to be maintaining this custom lock code for the next 20+ years, ensuring that it stays working properly under all conditions, do you? So, any chance to use something non-custom? thanks, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html