Hi, On Wed, Nov 07, 2012 at 04:12:47PM -0500, Alan Stern wrote: > This patch (as1630) cleans up a few minor items resulting from the > split-up of the ehci-hcd driver: > > Remove the product_desc string from the ehci_driver_overrides > structure. All drivers will use the generic "EHCI Host > Controller" string. (This was requested by Felipe Balbi.) > > Allow drivers to pass a NULL pointer to ehci_init_driver() > if they don't have to override any settings. > > Remove a #define symbol that is no longer used from the > ChipIdea host driver. > > Rename overrides to pci_overrides in ehci-pci.c, for > consistency with ehci-platform.c. > > Mark the *_overrides structures as __initdata. I just have one question here: What about all the ehci-*.c with their probe outside of .init.text ? $ git grep -e __devinit drivers/usb/host/ehci*.c drivers/usb/host/ehci-atmel.c:static int __devinit ehci_atmel_drv_probe(struct platform_device *pdev) drivers/usb/host/ehci-grlib.c:static int __devinit ehci_hcd_grlib_probe(struct platform_device *op) drivers/usb/host/ehci-orion.c:static int __devinit ehci_orion_drv_probe(struct platform_device *pdev) drivers/usb/host/ehci-platform.c:static int __devinit ehci_platform_probe(struct platform_device *dev) drivers/usb/host/ehci-ppc-of.c:static int __devinit drivers/usb/host/ehci-ppc-of.c:static int __devinit ehci_hcd_ppc_of_probe(struct platform_device *op) drivers/usb/host/ehci-ps3.c:static int __devinit ps3_ehci_probe(struct ps3_system_bus_device *dev) drivers/usb/host/ehci-s5p.c:static int __devinit s5p_ehci_probe(struct platform_device *pdev) drivers/usb/host/ehci-spear.c:static struct of_device_id spear_ehci_id_table[] __devinitdata = { drivers/usb/host/ehci-tegra.c:static struct of_device_id tegra_ehci_of_match[] __devinitdata = { drivers/usb/host/ehci-w90x900.c:static int __devinit usb_w90x900_probe(const struct hc_driver *driver, drivers/usb/host/ehci-w90x900.c:static int __devinit ehci_w90x900_probe(struct platform_device *pdev) drivers/usb/host/ehci-xilinx-of.c:static int __devinit ehci_hcd_xilinx_of_probe(struct platform_device *op) Other than that (and it might even be a stupid comment ;-), it looks good to me: Reviewed-by: Felipe Balbi <balbi@xxxxxx> -- balbi
Attachment:
signature.asc
Description: Digital signature