On Mon, Mar 5, 2012 at 5:13 PM, Sergei Shtylyov <sshtylyov@xxxxxxxxxx> wrote: > Hello. > > > On 05-03-2012 15:19, Keshava Munegowda wrote: > >> From: Keshava Munegowda<Keshava_mgowda@xxxxxx> > > >> The compilation of usb-host.c file was resulting compilation warning >> due to pointer type mismatch in assignment of return pointer type >> of the function omap_device_build_ss to local pointer type. >> This warning is fixed. > > >> Signed-off-by: Keshava Munegowda<keshava_mgowda@xxxxxx> >> --- >> arch/arm/mach-omap2/usb-host.c | 2 +- >> 1 files changed, 1 insertions(+), 1 deletions(-) > > >> diff --git a/arch/arm/mach-omap2/usb-host.c >> b/arch/arm/mach-omap2/usb-host.c >> index 771dc78..88d4a19 100644 >> --- a/arch/arm/mach-omap2/usb-host.c >> +++ b/arch/arm/mach-omap2/usb-host.c >> @@ -486,7 +486,7 @@ static void setup_4430ohci_io_mux(const enum >> usbhs_omap_port_mode *port_mode) >> void __init usbhs_init(const struct usbhs_omap_board_data *pdata) >> { >> struct omap_hwmod *oh[2]; >> - struct omap_device *od; >> + struct platform_device *od; > > > Makes sense to rename variable to 'pd' then. > > WBR, Sergei ya, and its already in mainline :) regards keshava -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html