Re: [PATCH] USB: debugging code shouldn't alter control flow

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> wrote:

> -	urb->transfer_flags &= allowed;
> +	allowed &= urb->transfer_flags;

Minor bikeshed here, but 'allowed' is not the right name for the value
at this point; perhaps just
        
	/* warn if submitter gave bogus flags */
	if ((urb->transfer_flags & allowed) != urb->transfer_flags)

might be better?

Otherwise, this looks nice to me.

Acked-by: Keith Packard <keithp@xxxxxxxxxx>

-- 
keith.packard@xxxxxxxxx

Attachment: pgpLGhwecs12r.pgp
Description: PGP signature


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux