Re: [PATCH experimental 5/6] usb: cdc-wdm: adding register/deregister

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Am Dienstag, 24. Januar 2012, 00:52:03 schrieb Bjørn Mork:
> +void wdm_deregister(struct usb_interface *intf)
> +{
> +       wdm_disconnect(intf);
> +}
> +EXPORT_SYMBOL(wdm_deregister);

Again, the names are too indistinct.

> +
>  #ifdef CONFIG_PM
>  static int wdm_suspend(struct usb_interface *intf, pm_message_t message)
>  {
> diff --git a/drivers/usb/class/cdc-wdm.h b/drivers/usb/class/cdc-wdm.h
> new file mode 100644
> index 0000000..ff6a47c
> --- /dev/null
> +++ b/drivers/usb/class/cdc-wdm.h

If we do this at all, we do it right and public. This belongs into include/linux/usb

	Regards
		Oliver
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux