Re: [RFC 1/6] usb/dummy_hcd: move the transfer part into its own function

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



* Alan Stern | 2011-12-08 14:26:46 [-0500]:

>> index ab8f1b4..bfba4aa 100644
>> --- a/drivers/usb/gadget/dummy_hcd.c
>> +++ b/drivers/usb/gadget/dummy_hcd.c
>> @@ -1140,6 +1140,23 @@ static int dummy_urb_dequeue(struct usb_hcd *hcd, struct urb *urb, int status)
>>  	return rc;
>>  }
>>  
>> +static int dummy_perform_transfer(struct urb *urb, struct dummy_request *req,
>> +		u32 len)
>> +{
>> +	void *ubuf, *rbuf;
>> +	int to_host;
>> +
>> +	to_host = usb_pipein(urb->pipe);
>> +	rbuf = req->req.buf + req->req.actual;
>> +	ubuf = urb->transfer_buffer += urb->actual_length;
>   	-----------------------------^
>Somehow + got changed to +=.  Same thing appeared in the next patch.

Thanks. The compiler did not complain nor did I noticed any transfer
errors.

>Alan Stern

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux