On Sat, Nov 20, 2010 at 02:13:23PM +0300, Sergei Shtylyov wrote: >> + >> + while (i--) { >> + if (ehci_readl(ehci,&ehci->regs->port_status[i]) & PORT_CSC) >> + return 1; >> + } > > {} not needed. scripts/checkpatch.pl doesn't complain? It doesn't! I think I find the braces more readable in this case, but I'm not wed to them. >> + >> + return 0; >> +} >> + >> static void ehci_adjust_port_wakeup_flags(struct ehci_hcd *ehci, >> bool suspending, bool do_wakeup) >> { >> int port; >> u32 temp; >> >> + > > Stray newline? Yeah, oops. I'll resend. -- Matthew Garrett | mjg59@xxxxxxxxxxxxx -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html