On Tue, 26 Oct 2010, [utf-8] MichaÅ? Nazarewicz wrote: > >> + if ((rc = device_create_file(&curlun->dev, &dev_attr_ro)) || > >> + (rc = device_create_file(&curlun->dev, &dev_attr_nofua)) || > >> + (rc = device_create_file(&curlun->dev, &dev_attr_file))) > >> + goto out; > > > > As long as you're changing these anyway, you may as well use the style > > most developers seem to prefer: > > > > rc = device_create_file(&curlun->dev, &dev_attr_ro); > > if (rc) > > goto out; > > ... > > But then it'd be total of 9 lines consisting of three 3-line ifs. I decided > that it would be more readable with a single if even though it is not compliant > with coding style. What do you think? I can just resend it. I think you should change it as I suggested. Alan Stern -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html