On 10/17/10 08:46, Igor Grinberg wrote: > Hi Alan, Sergei, > > On 10/11/10 17:27, Alan Stern wrote: >> On Mon, 11 Oct 2010, Igor Grinberg wrote: >> >>>>> - for (i = 0; i< ARRAY_SIZE(ulpi_ids); i++) >>>>> - if (ulpi_ids[i] == ULPI_ID(vid, pid)) >>>>> + for (i = 0; i< ARRAY_SIZE(ulpi_ids); i++) { >>>>> + if (ulpi_ids[i].id == ULPI_ID(vid, pid)) { >>>>> + pr_info("Found %s ULPI transceiver.\n", >>>>> + ulpi_ids[i].name); >>>>> break; >>>>> + } >>>>> + } >>>> Note that {} for the loop are not necessary. >>> Correct. >>> Though I think it improves the readability, because the statement in the loop >>> is a compound statement, but Documentation/CodingStyle says to get rid >>> of those, while making no difference between simple and compound statements. >>> I'll wait for some other comments (if any) and then repost. >> For what it's worth, I agree. The guidelines in >> Documentation/CodingStyle are not meant to be cast in stone as "the >> only way to do it". Linus has said many times that overall readability >> is more important. > I see... If that is the case, I'd like (if there are no further objections) > to have this patch (and the 1/2) at Greg's tree without resubmitting. Errr... It is already there... Thanks Greg :) -- Regards, Igor. -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html