Hi Greg A larget set of xhci cleanups, fixes, refactoring and features for usb-next. A bit late in the cycle but I wanted to get the endpoint stop/start race fix into this series as well. In addition to that fix there are several xhci cleanups and reworks, new tracing and debug entries, and some Etron vendor specific fixes. Thanks Mathias Andy Shevchenko (2): xhci: pci: Use standard pattern for device IDs xhci: pci: Fix indentation in the PCI device ID definitions Kuangyi Chiang (4): xhci: Combine two if statements for Etron xHCI host xhci: Don't issue Reset Device command to Etron xHCI host xhci: Fix control transfer error on Etron xHCI host xhci: Don't perform Soft Retry for Etron xHCI host Mathias Nyman (6): xhci: Add Isochronous TRB fields to TRB tracer xhci: Cleanup Candence controller PCI device and vendor ID usage xhci: show DMA address of TRB when tracing TRBs xhci: Don't trace ring at every enqueue or dequeue increase xhci: add stream context tracing xhci: trace stream context at Set TR Deq command completion Michal Pecio (5): usb: xhci: Remove unused parameters of next_trb() usb: xhci: Fix sum_trb_lengths() usb: xhci: Limit Stop Endpoint retries usb: xhci: Fix TD invalidation under pending Set TR Dequeue usb: xhci: Avoid queuing redundant Stop Endpoint commands Niklas Neronin (15): usb: xhci: introduce macro for ring segment list iteration usb: xhci: remove option to change a default ring's TRB cycle bit usb: xhci: adjust xhci_alloc_segments_for_ring() arguments usb: xhci: rework xhci_free_segments_for_ring() usb: xhci: refactor xhci_link_rings() to use source and destination rings usb: xhci: rework xhci_link_segments() usb: xhci: add xhci_initialize_ring_segments() usb: xhci: simplify TDs start and end naming scheme in struct 'xhci_td' usb: xhci: move link TRB quirk to xhci_gen_setup() usb: xhci: request MSI/-X according to requested amount usb: xhci: improve xhci_clear_command_ring() usb: xhci: remove unused arguments from td_to_noop() usb: xhci: refactor xhci_td_cleanup() to return void usb: xhci: add help function xhci_dequeue_td() usb: xhci: remove irrelevant comment WangYuli (1): xhci: debugfs: Add virt endpoint state to xhci debugfs drivers/usb/host/xhci-dbgcap.c | 13 +- drivers/usb/host/xhci-debugfs.c | 10 +- drivers/usb/host/xhci-mem.c | 235 ++++++++++++------------- drivers/usb/host/xhci-pci.c | 43 ++--- drivers/usb/host/xhci-ring.c | 296 +++++++++++++++++++------------- drivers/usb/host/xhci-trace.h | 79 ++++++--- drivers/usb/host/xhci.c | 78 ++++++--- drivers/usb/host/xhci.h | 49 ++++-- 8 files changed, 460 insertions(+), 343 deletions(-) -- 2.25.1