Hi Sundar, On Fri, Apr 26, 2024 at 10:17:05PM +0530, R Sundar wrote: > Nitpick, Mostly common path will not be indented. so rewritten this > function to check device_node pointer is null and removed common path > indentation. > > Signed-off-by: R Sundar <prosunofficial@xxxxxxxxx> For the record, I'm still uncomfortable with the name - why not just spell out your whole name? > --- > > Fixed nitpicks in code according to comments received on other patch as > below: > > [ Nit, this function should be rewritten to not work like this, the > "common" path should not be indented, but only the exception (i.e. bail > if ep is not allocated properly.) ] > https://lore.kernel.org/all/2024041103-doornail-professor-7c1e@gregkh/ > > Goal is to get rid of of_node_put,but sending this patch first to do one > thing at a time. > > Changes since v1 - fixed the typo error for spell from identation to > indentation > > Changes since v2 - Shifted the indentation to one level left for the > switch cases as per coding style. > > Changes since v3 - Added descriptive subject for the patch and checked > from and sign-off having same name. > > Changes since v4 - Fixed name in signed-off-by as in documents. > > Patches link: > ------------ > v1 - https://lore.kernel.org/all/20240420145522.15018-1-prosunofficial@xxxxxxxxx/ > v2 - https://lore.kernel.org/linux-usb/20240420164927.15290-1-prosunofficial@xxxxxxxxx/ > v3 - https://lore.kernel.org/all/20240421011647.3027-1-prosunofficial@xxxxxxxxx/ > v4 - https://lore.kernel.org/all/20240424150718.5006-1-prosunofficial@xxxxxxxxx/ > > drivers/usb/typec/mux/nb7vpq904m.c | 68 +++++++++++++++--------------- > 1 file changed, 34 insertions(+), 34 deletions(-) Sorry for missing this earlier, but it looks like this patch only modifies the nb7vpq904m driver, so I think you should specify that already in the subject. While at it, you could also specify the only function that is being modified in the commit message (this is just a suggestion): usb: typec: nb7vpq904m: Remove uneeded indentation In function nb7vpq904m_parse_data_lanes_mapping(), the "if (ep)" condition is basically the entire function. Making the code a bit more readable by inverting the condition so that the function returns immedately if there is no "ep". thanks, -- heikki