On Mon, Aug 28, 2023 at 07:00:22PM +0530, Krishna Kurapati wrote: > Add bindings to indicate properties required to support multiport > on Synopsys DWC3 controller. > > Suggested-by: Bjorn Andersson <quic_bjorande@xxxxxxxxxxx> > Signed-off-by: Krishna Kurapati <quic_kriskura@xxxxxxxxxxx> > Reviewed-by: Rob Herring <robh@xxxxxxxxxx> > --- > .../devicetree/bindings/usb/snps,dwc3.yaml | 13 +++++++------ > 1 file changed, 7 insertions(+), 6 deletions(-) > > diff --git a/Documentation/devicetree/bindings/usb/snps,dwc3.yaml b/Documentation/devicetree/bindings/usb/snps,dwc3.yaml > index a696f23730d3..5bc941355b43 100644 > --- a/Documentation/devicetree/bindings/usb/snps,dwc3.yaml > +++ b/Documentation/devicetree/bindings/usb/snps,dwc3.yaml > @@ -85,15 +85,16 @@ properties: > > phys: > minItems: 1 > - maxItems: 2 > + maxItems: 8 > > phy-names: > minItems: 1 > - maxItems: 2 > - items: > - enum: > - - usb2-phy > - - usb3-phy > + maxItems: 8 > + oneOf: > + - items: > + enum: [ usb2-phy, usb3-phy ] > + - items: > + pattern: "^usb[23]-port[0-3]$" Shouldn't this just be pattern: "^usb[23]-[0-3]$" so that it matches the names that are used by the nvidia bindings? We already have some inconsistency in that Amlogic uses a variant based on the legacy names that needlessly includes "phy" in the names: const: usb2-phy0 const: usb2-phy1 const: usb3-phy0 ... I don't think we should be introducing a third naming scheme here so I suggest just following the nvidia bindings. Johan