On Wed, Jun 21, 2023 at 10:06:19AM +0530, Krishna Kurapati wrote: > Add the compatible string for SC8280 Multiport USB controller from > Qualcomm. > > There are 4 power event irq interrupts supported by this controller > (one for each port of multiport). Added all the 4 as non-optional > interrupts for SC8280XP-MP > > Also each port of multiport has one DP and oen DM IRQ. Add all DP/DM > IRQ's related to 4 ports of SC8280XP Teritiary controller. > > Also added ss phy irq for both SS Ports. > > Signed-off-by: Krishna Kurapati <quic_kriskura@xxxxxxxxxxx> > + - if: > + properties: > + compatible: > + contains: > + enum: > + - qcom,sc8280xp-dwc3-mp > + then: > + properties: > + interrupts: You also need minItems 14 here. > + maxItems: 14 > + interrupt-names: And here, I think. > + items: > + - const: dp1_hs_phy_irq > + - const: dm1_hs_phy_irq > + - const: dp2_hs_phy_irq > + - const: dm2_hs_phy_irq > + - const: dp3_hs_phy_irq > + - const: dm4_hs_phy_irq > + - const: dp4_hs_phy_irq > + - const: dm4_hs_phy_irq > + - const: ss1_phy_irq > + - const: ss2_phy_irq > + - const: pwr_event_1 > + - const: pwr_event_2 > + - const: pwr_event_3 > + - const: pwr_event_4 The naming here is inconsistent and interrupts should not have "_irq" suffixes (even if some of the current ones do for historical reasons). I believe these should be named pwr_event_1 dp_hs_phy_1 dm_hs_phy_1 ss_phy_1 pwr_event_2 dp_hs_phy_2 dm_hs_phy_2 ss_phy_2 pwr_event_3 dp_hs_phy_3 dm_hs_phy_3 pwr_event_4 dp_hs_phy_4 dm_hs_phy_4 or similar and be grouped by port while using the the qcom,sc8280xp-dwc ordering for the individual lines. Side note: Please note how the above interrupt properties can also be used to infer the number of HS and SS ports. > + > additionalProperties: false > > examples: Johan